
<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns#" lang="en">
<head>

<meta property="fb:pages" content="130922415612" />
<meta name="blitz" content="mu-34e0cb7a-2e275a87-6dee8a8e-59cc4d44">
<meta property="fb:admins" content="nick.lattner" />
<meta property="fb:admins" content="jordan.joseffer" />
<meta property="fb:admins" content="SchmittyG" />
<meta property="fb:admins" content="sweetjerome" />
<meta property="fb:admins" content="mike.gilbert.WCZ" />
<meta property="fb:admins" content="cole.mathews.10" />
<meta charset="utf-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
<base href="/" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="Mason Silva,FORMER" />
<meta name="title" content="Mason Silva's &quot;Former&quot; Part" />
<meta name="description" content="Mason has been relentlessly cranking out top-notch footage and the onslaught won’t be stalling out anytime soon. High-speed and power-packed—this is s..." />
<meta name="generator" content="The Skateboarding Bible" />
<title>Thrasher Magazine - Mason Silva's &quot;Former&quot; Part</title>
<script src="/cdn-cgi/apps/head/CZIHORpg54CWtySA1DzbVm5Q4Ts.js"></script><link href="/templates/thrasher_protostar/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link rel="canonical" href="/articles/videos/mason-silva-s-former-part/" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@thrashermag">
<meta name="twitter:title" content="Mason Silva&#039;s &quot;Former&quot; Part">
<meta name="twitter:description" content="Mason has been relentlessly cranking out top-notch footage and the onslaught won&rsquo;t be stalling out anytime soon. High-speed and power-packed&mdash;this is skateboarding done right!">
<meta name="twitter:creator" content="@ThrasherMag">
<meta name="twitter:image:src" content="http://www.thrashermagazine.com//mediaV2/k2/items/cache/180fcdb7f41ac43d22bad8660f0e6c4e_L.jpg?t=1525968396">
<meta property="og:image" content="http://www.thrashermagazine.com//mediaV2/k2/items/cache/180fcdb7f41ac43d22bad8660f0e6c4e_L.jpg?t=1525968396" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="388" />
<meta property="og:title" content="Mason Silva's &quot;Former&quot; Part" />
<meta property="og:video:height" content="406" />
<meta property="og:type" content="video.other" />
<meta property="og:video:width" content="610" />
<meta property="og:video:type" content="application/x-shockwave-flash" />
<meta property="og:description" content="Mason has been relentlessly cranking out top-notch footage and the onslaught won&rsquo;t be stalling out anytime soon. High-speed and power-packed&mdash;this is skateboarding done right!" />
<meta property="og:video" content="https://player.ooyala.com/player.swf?embedCode=txam9hZjE6U9I1ghF-gCDJptKw2ZzAuJ&keepEmbedCode=true&options[showInAdControlBar]=true" />
<meta property="og:video:secure_url" content="https://player.ooyala.com/player.swf?embedCode=txam9hZjE6U9I1ghF-gCDJptKw2ZzAuJ&keepEmbedCode=true" />
<meta name="twitter:card" content="player"> <meta name="twitter:title" content="Mason Silva's " Former" Part" /> <meta name="twitter:description" content="Mason has been relentlessly cranking out top-notch footage and the onslaught won&rsquo;t be stalling out anytime soon. High-speed and power-packed&mdash;this is skateboarding done right!"> <meta name="twitter:image" content="http://www.thrashermagazine.com//mediaV2/k2/items/cache/180fcdb7f41ac43d22bad8660f0e6c4e_L.jpg?t=1525968396"> <meta name="twitter:player" content="https://player.ooyala.com/tframe.html?ec=txam9hZjE6U9I1ghF-gCDJptKw2ZzAuJ&pbid=febb9836f42a4527b0b1e69d2f9b9366&options[autoplay]=false&options[google-ima-ads-manager.showInAdControlBar]=true" "> <meta name="twitter:player:width" content="435"> <meta name="twitter:player:height" content="251">
<link href="/Fav_64.png" rel="shortcut icon" type="image/png" />
<link href="/Fav_32.png" rel="shortcut icon" type="image/png" />
<link rel="stylesheet" type="text/css" href="/templates/thrasher_protostar/css/styles.css?cache=021816V4" />
<link rel="stylesheet" type="text/css" href="/templates/thrasher_protostar/css/thrasher_flexible.css?cache=030717V1" />
<script src="/templates/thrasher_protostar/js/thrasher_compiled.js?cache=08V4" type="text/javascript"></script>
<script src="/templates/thrasher_protostar/js/thrasher_flexible.js?cache=08V4" type="text/javascript"></script>
<link href="/templates/thrasher_protostar/html/flipJS/lity-2.2.0/dist/lity.css" rel="stylesheet"></link>
<script src="/templates/thrasher_protostar/html/flipJS/lity-2.2.0/dist/lity.js" type="text/javascript" charset="utf-8"></script>
<script type="application/javascript" src="https://api.ipify.org?format=jsonp&callback=getIP"></script>
<script src='/codePlayground/BlockAdBlock/blockadblock.js'></script>
<script src='//player.ooyala.com/v3/febb9836f42a4527b0b1e69d2f9b9366?platform=html5-priority'></script>
<script src='/templates/thrasher_protostar/js/Notify/jquery.notifyBar.js'></script>
<link rel="stylesheet" href="/templates/thrasher_protostar/js/Notify/css/jquery.notifyBar.css">
<script src="http://www.thrashermagazine.com//templates/protostar/js/Sharrre/jquery.sharrre.min.js" type="text/javascript"></script>
</head>
<body class="rollover-enabled">
<script type="text/javascript">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</script>
<div id="fb-root"></div> 
<div class="site-container">
<div class="site-content">
<div class="faux-body">
<div class="bkg-container"></div>
<div class="main-content-container">
<div class="main-content">
<div class="ad-container top-ad"></div>
<div class="header">
<h1 class="title"><a class="title-link" href="/">Thrasher Magazine</a></h1>
<a class="menu-button" href="#menu">Menu</a>
<div class="header-menu">



<div class="search itp-gs">
<form class="search-form" action="/search/" method="get" accept-charset="utf-8">

<label class="search-label" for="s">Search</label>
<input type="text" class="inputbox search-field" id="search" name="searchFor" autocomplete="off">
<input type="submit" class="btn search-button" value="Search" />

</form>
</div>
<ul class="nav menu main-nav">
<li class="item-101 main-nav-home"><div class="main-nav-section-item-container">
<div class="main-nav-section-item"><a class='main-nav-section-link home' href="/"><span class="text">Home</span></a></div>
</div>
</li>
<li class="item-285 main-nav-section deeper parent"><div class="main-nav-section-item-container">
<div class="main-nav-section-item">
<span class="nav-header  main-nav-section-title features">
<span class="text">Features</span>
</span>
</div>
</div>
<div class="main-nav-section-list-container">
<div class="main-nav-section-list-inner-container">
<ul class="nav-child main-nav-section-list unstyled small">
<li class="item-325 main-nav-section-list-item first"><a class='item-link burnout' href="/burnout/"><span class="text">Burnout</span></a>
</li>
<li class="item-286 main-nav-section-list-item"><a class='item-link bust or bail' href="/articles/videos/bust-or-bail-2-the-ripper-at-clipper/"><span class="text">Bust or Bail</span></a>
</li>
<li class="item-289 main-nav-section-list-item"><a class='item-link dc promo' href="/dc-promo/"><span class="text">DC Promo</span></a>
</li>
<li class="item-304 main-nav-section-list-item"><a class='item-link bffs' href="/bffs/"><span class="text">BFFS</span></a>
</li>
<li class="item-323 main-nav-section-list-item"><a class='item-link king of the road' href="/king-of-the-road/"><span class="text">King of the Road</span></a>
</li>
<li class="item-326 main-nav-section-list-item"><a class='item-link skate rock' href="/skate-rock/"><span class="text">Skate Rock</span></a>
</li>
<li class="item-400 main-nav-section-list-item"><a class='item-link lakai extra flare' href="/extra-flare/"><span class="text">Lakai Extra Flare</span></a>
</li>
<li class="item-401 main-nav-section-list-item"><a class='item-link rough cuts' href="/rough-cut/"><span class="text">Rough Cuts</span></a></li>
<li class="clear"></li>
</ul></div></div>
</li>
<li class="item-142 main-nav-section deeper parent"><div class="main-nav-section-item-container">
<div class="main-nav-section-item"><a class='nav-header main-nav-section-link shop' href="http://shop.thrashermagazine.com"><span class="text">Shop</span></a></div>
</div>
<div class="main-nav-section-list-container">
<div class="main-nav-section-list-inner-container">
<ul class="nav-child main-nav-section-list unstyled small">
<li class="item-144 main-nav-section-list-item first"><a class='item-link web specials' href="http://shop.thrashermagazine.com" target="_blank"><span class="text">Web Specials</span></a>
</li>
<li class="item-143 main-nav-section-list-item"><a class='item-link subscriptions' href="http://shop.thrashermagazine.com/subscriptions.html" target="_blank"><span class="text">Subscriptions</span></a>
</li>
<li class="item-290 main-nav-section-list-item"><a class='item-link t-shirts' href="http://shop.thrashermagazine.com/clothing/shirts/t-shirts.html" target="_blank"><span class="text">T-Shirts</span></a>
</li>
<li class="item-291 main-nav-section-list-item"><a class='item-link sweatshirts' href="http://shop.thrashermagazine.com/clothing/sweatshirts.html" target="_blank"><span class="text">Sweatshirts</span></a>
</li>
<li class="item-292 main-nav-section-list-item"><a class='item-link back issues' href="http://shop.thrashermagazine.com/magazines/back-issues.html" target="_blank"><span class="text">Back Issues</span></a>
</li>
<li class="item-293 main-nav-section-list-item"><a class='item-link accessories' href="http://shop.thrashermagazine.com/special-offers" target="_blank"><span class="text">Accessories</span></a></li>
<li class="clear"></li>
</ul></div></div>
</li>
<li class="item-113 main-nav-section deeper parent"><div class="main-nav-section-item-container">
<div class="main-nav-section-item">
<span class="nav-header  main-nav-section-title video">
<span class="text">Video</span>
</span>
</div>
</div>
<div class="main-nav-section-list-container">
<div class="main-nav-section-list-inner-container">
<ul class="nav-child main-nav-section-list unstyled small">
<li class="item-324 main-nav-section-list-item first"><a class='item-link most recent' href="/articles/videos/"><span class="text">Most Recent</span></a>
</li>
<li class="item-156 main-nav-section-list-item"><a class='item-link firing line' href="/firing-line/"><span class="text">Firing Line</span></a>
</li>
<li class="item-278 main-nav-section-list-item"><a class='item-link full parts' href="/full-parts/"><span class="text">Full Parts</span></a>
</li>
<li class="item-157 main-nav-section-list-item"><a class='item-link hall of meat' href="/hall-of-meat/"><span class="text">Hall of Meat</span></a>
</li>
<li class="item-160 main-nav-section-list-item"><a class='item-link double rock' href="/double-rock/"><span class="text">Double Rock</span></a>
</li>
<li class="item-140 main-nav-section-list-item"><a class='item-link greatest hits' href="/greatest-hits/"><span class="text">Greatest Hits</span></a>
</li>
<li class="item-141 main-nav-section-list-item"><a class='item-link king of the road' href="/king-of-the-road/"><span class="text">King of the Road</span></a>
</li>
<li class="item-301 main-nav-section-list-item"><a class='item-link magnified' href="/magnified/"><span class="text">Magnified</span></a>
</li>
<li class="item-302 main-nav-section-list-item"><a class='item-link bruray' href="/bruray/"><span class="text">BruRay</span></a>
</li>
<li class="item-303 main-nav-section-list-item"><a class='item-link skateline' href="/skateline/"><span class="text">Skateline</span></a>
</li>
<li class="item-305 main-nav-section-list-item"><a class='item-link classics' href="/classics/"><span class="text">Classics</span></a>
</li>
<li class="item-306 main-nav-section-list-item"><a class='item-link classic covers' href="/classic-covers/"><span class="text">Classic Covers</span></a>
</li>
<li class="item-307 main-nav-section-list-item"><a class='item-link hot spot' href="/hot-spot/"><span class="text">Hot Spot</span></a>
</li>
<li class="item-309 main-nav-section-list-item"><a class='item-link traffic talk' href="/traffic-talk/"><span class="text">Traffic Talk</span></a>
</li>
<li class="item-311 main-nav-section-list-item"><a class='item-link time bomb' href="/time-bomb/"><span class="text">Time Bomb</span></a>
</li>
<li class="item-312 main-nav-section-list-item"><a class='item-link my war' href="/my-war/"><span class="text">My War</span></a>
</li>
<li class="item-308 main-nav-section-list-item"><a class='item-link first look' href="/first-look/"><span class="text">First Look</span></a>
</li>
<li class="item-399 main-nav-section-list-item"><a class='item-link contests' href="/contests/"><span class="text">Contests</span></a></li>
<li class="clear"></li>
</ul></div></div>
</li>
<li class="item-295 main-nav-section deeper parent"><div class="main-nav-section-item-container">
<div class="main-nav-section-item">
<span class="nav-header  main-nav-section-title magazine">
<span class="text">Magazine</span>
</span>
</div>
</div>
<div class="main-nav-section-list-container">
<div class="main-nav-section-list-inner-container">
<ul class="nav-child main-nav-section-list unstyled small">
<li class="item-297 main-nav-section-list-item first"><a class='item-link subscribe' href="http://shop.thrashermagazine.com/subscriptions.html"><span class="text">Subscribe</span></a>
</li>
<li class="item-298 main-nav-section-list-item"><a class='item-link submissions' href="/user-help/photo-and-editorial-submission-guidelines/"><span class="text">Submissions</span></a>
</li>
<li class="item-299 main-nav-section-list-item"><a class='item-link archive' href="/articles/covers/covers-index/"><span class="text">Archive</span></a>
</li>
<li class="item-300 main-nav-section-list-item"><a class='item-link articles and interviews' href="/articles-and-interviews/"><span class="text">Articles and Interviews</span></a></li>
<li class="clear"></li>
</ul></div></div>
</li>
<li class="item-294 main-nav-section"><div class="main-nav-section-item-container">
<div class="main-nav-section-item"><a class='main-nav-section-link events' href="/events/"><span class="text">Events</span></a></div>
</div>
</li>
<li class="item-145 main-nav-section deeper parent"><div class="main-nav-section-item-container">
<div class="main-nav-section-item">
<span class="nav-header  main-nav-section-title more">
<span class="text">More</span>
</span>
</div>
</div>
<div class="main-nav-section-list-container">
<div class="main-nav-section-list-inner-container">
<ul class="nav-child main-nav-section-list unstyled small">
<li class="item-313 main-nav-section-list-item first"><a class='item-link contact us' href="/user-help/contact/"><span class="text">Contact Us</span></a>
</li>
<li class="item-314 main-nav-section-list-item"><a class='item-link advertising contact' href="/k2/advertising/contact-2/"><span class="text">Advertising Contact</span></a>
</li>
<li class="item-315 main-nav-section-list-item"><a class='item-link site map' href="/user-help/site-map/"><span class="text">Site Map</span></a>
</li>
<li class="item-316 main-nav-section-list-item"><a class='item-link submission guidelines' href="/user-help/photo-and-editorial-submission-guidelines/"><span class="text">Submission Guidelines</span></a>
</li>
<li class="item-317 main-nav-section-list-item"><a class='item-link shop faq' s'href="http://shop.thrashermagazine.com/customer-service" target="_blank"><span class="text">Shop FAQ's</span></a></li>
<li class="clear"></li>
</ul></div></div>
</li>
</ul>
<ul class="social-list">
<li class="social-list-item"><a class="social-list-item-link mailing-list" href="http://visitor.r20.constantcontact.com/d.jsp?llr=mhhtnxcab&p=oi&m=1102445124844&sit=tguhsg6db&f=bcfdcfe1-f3dd-457d-8874-837de38e03da" target="_blank"><span class="icon">Mailing List</span></a></li>
<li class="social-list-item"><a class="social-list-item-link facebook" href="https://www.facebook.com/ThrasherMagazine/" target="_blank"><span class="icon">Facebook</span></a></li>
<li class="social-list-item"><a class="social-list-item-link instagram" href="https://instagram.com/thrashermag/" target="_blank"><span class="icon">Instagram</span></a></li>
<li class="social-list-item"><a class="social-list-item-link twitter" href="https://twitter.com/thrashermag" target="_blank"><span class="icon">Twitter</span></a></li>
<li class="social-list-item"><a class="social-list-item-link youtube" href="https://www.youtube.com/user/ThrasherMagazine" target="_blank"><span class="icon">YouTube</span></a></li>
</ul>
</div> 
</div> 
<div class="page-content-container">
<script src='//player.ooyala.com/v3/febb9836f42a4527b0b1e69d2f9b9366?tweaks=test'></script>
<div class="page-content article two-column">
<script type="application/json" class="page-data">
    {
      "ad_test_key": "Mason Silva"
    }
  </script>
<div class="page-header quick-flow">
<script class="quick-flow-data" id="test-id" type="application/json">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</script>
<div class="page-header-content">
<div class="quick-flow-path-container above-video">
<a class="quick-flow-list-link" href="/"><span class="text">More </span></a>
</div>
<div class="quick-flow-button-container prev">
<div class="quick-flow-button-inner-container">
<a class="quick-flow-button adjacent-article" href="/articles/videos/magnfied-chris-joslin/">
<span class="arrow-icon"></span>
<span class="text">
<span class="label">Older:</span>
<span class="title">Magnfied: Chris Joslin</span>
</span>
</a>
</div>
</div>
<div class="quick-flow-button-container next">
<div class="quick-flow-button-inner-container">
<a class="quick-flow-button adjacent-article" href="/articles/videos/rough-cut-jb-gillet-s-nike-o-mok-part/">
<span class="arrow-icon"></span>
<span class="text">
<span class="label">Newer:</span>
<span class="title">Rough Cut: JB Gillet’s "Nike-O-Mok" Part</span>
</span>
</a>
</div>
</div>
<div class="clear"></div>
</div> 
</div> 
<div class="primary-content">
<div class="article" data-ad-test-key="Mason Silva">
<div class="article-hero-container">
<div class="hero-video-placeholder" data-hero-video-provider="OOyala" data-hero-video-id="txam9hZjE6U9I1ghF-gCDJptKw2ZzAuJ">
<p class="video-no-js-message">Sorry, you must be using a <a href="http://browsehappy.com/" target="_blank">modern browser</a> with JavaScript enabled to view videos.</p>
</div>
</div>
<div class="article-content">
<div class="article-header">
<h3 class="article-title">Mason Silva&#039;s &quot;Former&quot; Part</h3>
</div>
<div class="article-body">
<div class="article-date" data-timestamp="1525998924">5/10/2018</div>
<div class="article-text"><div class="body-text"><p id="truncateMe">Mason has been relentlessly cranking out top-notch footage and the onslaught won’t be stalling out anytime soon. High-speed and power-packed—this is skateboarding done right!</p> </div></div>
<div class="article-tags">
<ul class="tag-list">
<li class="tag-list-item"><a class="tag-list-link" href="/tag/mason-silva/" data-video-previews-url="http://www.thrashermagazine.com/templates/thrasher_protostar/html/globalIncludes/quickFlowGetter.php?cacheBuster=1&amp;outsideRequest=true&amp;previews=true&amp;tagOverride=2054">Mason Silva</a></li>
<b></b>
<li class="tag-list-item"><a class="tag-list-link" href="/tag/former/" data-video-previews-url="http://www.thrashermagazine.com/templates/thrasher_protostar/html/globalIncludes/quickFlowGetter.php?cacheBuster=1&amp;outsideRequest=true&amp;previews=true&amp;tagOverride=6422">FORMER</a></li>
<b></b>
</ul>
<div class="clear"></div>
</div>
<div class="article-share-placeholder" data-share-url="http://www.thrashermagazine.com/articles/videos/mason-silva-s-former-part/" data-share-title="Mason Silva&amp;#039;s &amp;quot;Former&amp;quot; Part" data-share-text="Mason has been relentlessly cranking out top-notch footage and the onslaught won&amp;rsquo;t be stalling out anytime soon. High-speed and power-packed&amp;mdash;this is skateboarding done right!" data-embed-code="&lt;iframe class=&quot;ThrasherVideo&quot; width=&quot;610&quot; height=&quot;343&quot; frameborder=&quot;0&quot; style=&quot;margin:0px;padding:0px;border:0px;&quot; src=&quot;http://www.thrashermagazine.com/Embed.php?ooyalaId=txam9hZjE6U9I1ghF-gCDJptKw2ZzAuJ&amp;Remote=1&amp;Width=610&quot;&gt;&lt;/iframe&gt;"></div>
</div>
<div class="article-collapsible-container">
<div class="article-collapsible">
<div class="comments">
<div class="comments-placeholder" data-comments-link="http://www.thrashermagazine.com/articles/videos/mason-silva-s-former-part/"></div>
</div>
</div>
</div> 
</div> 
</div> 
</div> 
<div class="secondary-content">

 <ul class="post-list"><li class="post-list-item default first">
<div class="post-date" data-timestamp="5/07/2018">5/07/2018</div>
<h4 class="post-title"><a class="post-title-link" href="/articles/vans-pool-party-2018-photos/" title="Vans Pool Party 2018 Photos">Vans Pool Party 2018 Photos</a></h4>
<div class="post-thumb-container">
<a class="post-thumb-link" href="/articles/vans-pool-party-2018-photos/" title="Vans Pool Party 2018 Photos">
<img class="post-thumb" src="/mediaV2/k2/items/cache/32a2b740e9963023cf49eb9616e80136_S.jpg?t=1525731848" alt="Vans Pool Party 2018 Photos" data-width="208" data-height="117" />
</a>
</div>
<div class="post-description">This year’s Pool Party was even more festive than usual as it fell on Cinco De Mayo, and the opening ceremony was kicked off with a traditional mariachi band cranking out tunes next to the bowl.</div>
<div class="clear"></div>
<div class="social-container"><div class="share-socials" data-url="http://www.thrashermagazine.com/articles/vans-pool-party-2018-photos/" data-title="Share" data-text="This year’s Pool Party was even more festive than usual as it fell on Cinco De Mayo, and the opening ceremony was kicked off with a traditional mariachi band cranking out tunes next to the bowl."></div></div>
</li><li class="post-list-item default">
<div class="post-date" data-timestamp="5/07/2018">5/07/2018</div>
<h4 class="post-title"><a class="post-title-link" href="/articles/videos/first-look-mason-silva-and-louie-lopez/" title="First Look: Mason Silva and Louie Lopez">First Look: Mason Silva and Louie Lopez</a></h4>
<div class="post-thumb-container">
<a class="post-thumb-link" href="/articles/videos/first-look-mason-silva-and-louie-lopez/" title="First Look: Mason Silva and Louie Lopez">
<img class="post-thumb" src="/mediaV2/k2/items/cache/64f092ad535d477fae380c7c7cbe0365_S.jpg?t=1525721335" alt="First Look: Mason Silva and Louie Lopez" data-width="208" data-height="117" />
</a>
</div>
<div class="post-description">Mason Silva and Louie Lopez tear through the new mag alongside a special guest who’s also named Louie.</div>
<div class="clear"></div>
<div class="social-container"><div class="share-socials" data-url="http://www.thrashermagazine.com/articles/videos/first-look-mason-silva-and-louie-lopez/" data-title="Share" data-text="Mason Silva and Louie Lopez tear through the new mag alongside a special guest who’s also named Louie."></div></div>
</li><li class="post-list-item default">
<div class="post-date" data-timestamp="4/23/2018">4/23/2018</div>
<h4 class="post-title"><a class="post-title-link" href="/articles/videos/rough-cut-mason-silva-s-golden-foytime-footage/" title="Rough Cut: Mason Silva&amp;#039;s &amp;quot;Golden Foytime&amp;quot; Footage">Rough Cut: Mason Silva&#039;s &quot;Golden Foytime&quot; Footage</a></h4>
<div class="post-thumb-container">
<a class="post-thumb-link" href="/articles/videos/rough-cut-mason-silva-s-golden-foytime-footage/" title="Rough Cut: Mason Silva&amp;#039;s &amp;quot;Golden Foytime&amp;quot; Footage">
<img class="post-thumb" src="/mediaV2/k2/items/cache/470c1cc13462ae89e7ba41ceb2fa6228_S.jpg?t=1524521325" alt="Rough Cut: Mason Silva&amp;#039;s &amp;quot;Golden Foytime&amp;quot; Footage" data-width="208" data-height="117" />
</a>
</div>
<div class="post-description">Mason cruised down to OZ on the SOTY trip and absolutely slaughtered everything in his path. The dude is a one-man demolition squad.</div>
<div class="clear"></div>
<div class="social-container"><div class="share-socials" data-url="http://www.thrashermagazine.com/articles/videos/rough-cut-mason-silva-s-golden-foytime-footage/" data-title="Share" data-text="Mason cruised down to OZ on the SOTY trip and absolutely slaughtered everything in his path. The dude is a one-man demolition squad."></div></div>
</li><li class="post-list-item default">
<div class="post-date" data-timestamp="3/15/2018">3/15/2018</div>
<h4 class="post-title"><a class="post-title-link" href="/articles/soty-video-premiere-2018/" title="SOTY Video Premiere">SOTY Video Premiere</a></h4>
<div class="post-thumb-container">
<a class="post-thumb-link" href="/articles/soty-video-premiere-2018/" title="SOTY Video Premiere">
<img class="post-thumb" src="/mediaV2/k2/items/cache/5ed6903e1e95da1880f8be8a656cd3b0_S.jpg?t=1521145413" alt="SOTY Video Premiere" data-width="208" data-height="117" />
</a>
</div>
<div class="post-description">The SOTY Oz Video premiered in Long Beach a few nights ago and all the good homies came out to get a sneak peek. Peep game and get ready for the vid dropping soon!&nbsp;</div>
<div class="clear"></div>
<div class="social-container"><div class="share-socials" data-url="http://www.thrashermagazine.com/articles/soty-video-premiere-2018/" data-title="Share" data-text="The SOTY Oz Video premiered in Long Beach a few nights ago and all the good homies came out to get a sneak peek. Peep game and get ready for the vid dropping soon!&amp;nbsp;"></div></div>
</li><li class="post-list-item default">
<div class="post-date" data-timestamp="3/06/2018">3/06/2018</div>
<h4 class="post-title"><a class="post-title-link" href="/articles/videos/skatepark-round-up-element/" title="Skatepark Round-Up: Element">Skatepark Round-Up: Element</a></h4>
<div class="post-thumb-container">
<a class="post-thumb-link" href="/articles/videos/skatepark-round-up-element/" title="Skatepark Round-Up: Element">
<img class="post-thumb" src="/mediaV2/k2/items/cache/f79f601d559fde97873c162551e90668_S.jpg?t=1520359211" alt="Skatepark Round-Up: Element" data-width="208" data-height="117" />
</a>
</div>
<div class="post-description">The Element team sparked things at the Vista park before heading inside for a special surprise. There’s even a Bam clip involved...</div>
<div class="clear"></div>
<div class="social-container"><div class="share-socials" data-url="http://www.thrashermagazine.com/articles/videos/skatepark-round-up-element/" data-title="Share" data-text="The Element team sparked things at the Vista park before heading inside for a special surprise. There’s even a Bam clip involved..."></div></div>
</li> </ul>
<div class="ad-container pad-top"></div>
</div> 
</div> 
<script type="text/javascript">
//  $.get( "http://api.ipify.org?format=json", function( data ) {
// youRoll = data;
// if(youRoll['ip'] =="173.8.165.85"){
var s = document.createElement("script");
s.type = "text/javascript";
s.src = "/codePlayground/advertisement.js";
$("head").append(s);
$(function(){ if($.ads != undefined)  jQuery('.AddPreRoll', '.body-text').replaceWith("<iframe class='videoMain' allowfullscreen src='/codePlayground/adBlockDetectAndYoutubePreRollTest.php?id=20054&test=524847454' frameborder='0' style='width:100%;height:100%;'></iframe>");
 });




// }
// }, "json");
</script>


<script type="text/javascript">
//   function makeCookie(name, value, p) {
//         var s, k;

//         function reldate(days) {
//             var d;
//             d = new Date();
//             d.setTime(d.getTime() + days * 86400000);
//             return d.toGMTString();
//         }
//         s = escape(name) + '=' + escape(value);
//         if (p)
//             for (k in p) {

//                 /* convert a numeric expires value to a relative date */

//                 if (k == 'expires')
//                     p[k] = isNaN(p[k]) ? p[k] : reldate(p[k]);

//                 /* The secure property is the only special case
// here, and it causes two problems. Rather than
// being '; protocol=secure' like all other
// properties, the secure property is set by
// appending '; secure', so we have to use a
// ternary statement to format the string.

// The second problem is that secure doesn't have
// any value associated with it, so whatever value
// people use doesn't matter. However, we don't
// want to surprise people who set { secure: false }.
// For this reason, we actually do have to check
// the value of the secure property so that someone
// won't end up with a secure cookie when
// they didn't want one. */

//                 if (p[k])
//                     s += '; ' + (k != 'secure' ? k + '=' + p[k] : k);
//             }
//         document.cookie = s;
//         return readCookie(name) == value;
//     }

//     function readCookie(name) {
//         var s = document.cookie,
//             i;
//         if (s)
//             for (i = 0, s = s.split('; '); i < s.length; i++) {
//                 s[i] = s[i].split('=', 2);
//                 if (unescape(s[i][0]) == name)
//                     return unescape(s[i][1]);
//             }
//         return null;
//     }

//     function removeCookie(name) {
//         return !makeCookie(name, '', {
//             expires: -1
//         });
//     }

//   function freshVisitor(howFresh) {
//     var namespace = 'Preston';
//     if (readCookie(namespace)) {
//         return false;
//     }
//     return makeCookie(namespace, 'yes', {
//         expires: howFresh || 1
//     });
// }
//   var now = new Date();
//   var runTime = new Date();
//   runTime.setMonth(9);
//   if(now.getMonth() <= runTime.getMonth()){
// if(freshVisitor()==true){
//   jQuery(document).ready(function($) {
//   ThrasherLightbox.sweep(jQuery(".interstitialHolder"));
//   jQuery('.Interstitial').trigger("click");
// });
// }
// }else{
//   console.log("not time yet");
// }
  </script>
</div> 
</div> 
</div> 
<div class="main-footer-container">
<div class="main-footer">
<div class="copyright">&copy; 1981&ndash;2018 High Speed Productions, Inc.</div>
</div>
</div> 
</div> 
</div> 
</div> 
<script class="post-list-item-default" type="text/mustache"><li class="post-list-item default{{#first}} first{{/first}}">
  <div class="post-date" data-timestamp="{{timestamp}}">{{{date_html}}}</div>
  <h4 class="post-title"><a class="post-title-link" href="/{{link_url}}" title="{{link_title}}">{{{title_html}}}</a></h4>
  <div class="post-thumb-container">
    <a class="post-thumb-link" href="/{{link_url}}" title="{{link_title}}">
    <img class="post-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" data-width="{{image_width}}" data-height="{{image_height}}" {{#image_class}}data-image-class="{{image_class}}" {{/image_class}}/>
    </a>
  </div>
  <div class="post-description">{{{description_html}}}</div>
  <div class="clear"></div>
  <div class="social-container"><div class="share-socials" data-url="{{share_link}}" data-title="{{share_title}}" data-text="{{share_text}}"></div></div>
</li></script>
<script class="post-list-item-junk-drawer" type="text/mustache"><li class="post-list-item junk-drawer-item{{#first}} first{{/first}}">
  <h4 class="post-title"><a class="post-title-link" href="/{{link_url}}" title="{{link_title}}">{{{title_html}}}</a></h4>
  <div class="post-thumb-container" style="">
    <a class="post-thumb-link" href="/{{link_url}}" title="{{link_title}}">
      <img class="post-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" />
    </a>
  </div>
  <div class="post-description">{{{description_html}}}</div>
  
  <div class="social-outer-container clear"><div class="social-container"><div class="share-socials" data-url="{{share_link}}" data-title="{{share_title}}" data-text="{{share_text}}"></div></div></div>
  
</li></script>
<script class="post-list-item-featured" type="text/mustache"><li class="post-list-item featured{{#first}} first{{/first}}">
  <div class="post-thumb-container">
    <a class="post-thumb-link" href="/{{link_url}}" title="{{link_title}}">
      <img class="post-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" />
    </a>
  </div>
  <h4 class="post-title"><a class="post-title-link" href="/{{link_url}}" title="{{link_title}}">{{{title_html}}}</a></h4>
  <div class="post-description">{{{description_html}}}</div>
</li></script>
<script class="post-list-item-listing" type="text/mustache"><li class="post-list-item listing{{#first}} first{{/first}}">
  <div class="post-thumb-container">
    <a class="post-thumb-link" href="/{{link_url}}" title="{{link_title}}">
      <img class="post-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" />
    </a>
  </div>
  <div class="post-content-container">
    <h4 class="post-title"><a class="post-title-link" href="/{{link_url}}" title="{{link_title}}">{{{title_html}}}</a></h4>
    <div class="post-description">{{{description_html}}}</div>
    <div class="social-container"><div class="share-socials" data-url="{{share_link}}" data-title="{{share_title}}" data-text="{{share_text}}"></div></div>
  </div>
  <div class="clear"></div>
</li></script>
<script class="post-list-item-secondary" type="text/mustache"><li class="post-list-item secondary{{#first}} first{{/first}}">
  <h4 class="post-title"><a class="post-title-link" href="/{{link_url}}" title="{{link_title}}">{{{title_html}}}</a></h4>
  <div class="post-thumb-container" style="">
    <a class="post-thumb-link" href="/{{link_url}}" title="{{link_title}}">
      <img class="post-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" />
    </a>
  </div>
  <div class="post-description">{{{description_html}}}</div>
  <div class="clear"></div>
</li></script>
<script class="post-list-item-search-results" type="text/mustache"><li class="post-list-item search-results-item{{#first}} first{{/first}}">
  <div class="post-thumb-container">
    <a class="post-thumb-link" href="/{{link_url}}" title="{{link_title}}">
      <img class="post-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" />
    </a>
  </div>
  <div class="post-content-container">
    <h4 class="post-title"><a class="post-title-link" href="/{{link_url}}" title="{{link_title}}">{{{title_html}}}</a></h4>
    <div class="post-description">{{{description_html}}}</div>
    <div class="social-container"><div class="share-socials" data-url="{{share_link}}" data-title="{{share_title}}" data-text="{{share_text}}"></div></div>
  </div>
  <div class="clear"></div>
</li></script>
<script class="preview-list-item" type="text/mustache"><li class="preview-list-item">
  <a class="preview-link" href="/{{link_url}}" title="{{link_title}}" data-article-id="{{article_id}}">
    <img class="preview-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" />
    <span class="preview-title">{{{title_html}}}</span>
  </a>
</li></script>
<script class="preview-slider-item" type="text/mustache"><li class="preview-slider-list-item{{#first}} first{{/first}}">
  <a class="preview-link" href="/{{link_url}}" title="{{link_title}}" data-article-id="{{article_id}}">
    <span class="thumb-container"><img class="preview-thumb{{#image_class}} {{image_class}}{{/image_class}}" src="/{{image_url}}" alt="{{image_alt}}" /></span>
    <span class="preview-title-container"><span class="preview-title">{{{title_html}}}</span></span>
  </a>
</li></script>
<script class="article" type="text/mustache"><div class="article"{{#ad_test_key}} data-ad-test-key="{{ad_test_key}}"{{/ad_test_key}}>
  
  {{#landing_page_header}}<div class="landing-page-header-container" data-header="{{landing_page_header}}" data-size="{{landing_page_size}}" data-link="{{landing_page_link}}"></div>{{/landing_page_header}}
  
  {{#has_hero}}
  <div class="article-hero-container">
    
    {{#hero_image_url}}
    <img class="article-image" src="/{{hero_image_url}}" alt="{{hero_image_url}}" />
    {{/hero_image_url}}
      
    {{#hero_video_id}}
    <div class="hero-video-placeholder" data-hero-video-provider="{{hero_video_provider}}" data-hero-video-id="{{hero_video_id}}">
      <p class="video-no-js-message">Sorry, you must be using a <a href="http://browsehappy.com/" target="_blank">modern browser</a> with JavaScript enabled to view videos.</p>
    </div>
    {{/hero_video_id}}
  
  </div>
  {{/has_hero}}

  <div class="article-content">
  
    <div class="article-header">
      <h3 class="article-title">{{{title_html}}}</h3>
    </div>
    
    <div class="article-body">
      <div class="article-date" data-timestamp="{{timestamp}}">{{{date_html}}}</div>
      
      <div class="article-text"><div class="body-text">{{{text_html}}}</div></div>
      
      {{#has_tags}}
      <div class="article-tags">
        <ul class="tag-list">
          {{#tags}}
          <li class="tag-list-item"><a class="tag-list-link" href="/{{tag_link}}"{{#tag_video_previews_url}} data-video-previews-url="{{tag_video_previews_url}}"{{/tag_video_previews_url}}>{{tag_name}}</a></li>
          <b></b>
          {{/tags}}
        </ul>
        <div class="clear"></div>
      </div>
      {{/has_tags}}
      
      <div class="article-share-placeholder" data-share-url="{{share_link}}" data-share-title="{{share_title}}" data-share-text="{{share_text}}"{{#hero_video_iframe}} data-embed-code="{{{hero_video_iframe}}}"{{/hero_video_iframe}}></div>
      
    </div>
    
    <div class="article-collapsible-container">
      <div class="article-collapsible">

        {{#comments_enabled}}
        <div class="comments">
          <div class="comments-placeholder" data-comments-link="http://www.thrashermagazine.com{{comments_link}}"></div>
        </div>
        {{/comments_enabled}}
      </div>
    </div> <!-- .article-collapsible-container -->
    
  </div> <!-- .article-content -->

</div> <!-- .article --></script>
<script class="feature_article" type="text/mustache"><div class="article"{{#ad_test_key}} data-ad-test-key="{{ad_test_key}}"{{/ad_test_key}}>
  
  {{#landing_page_header}}<div class="landing-page-header-container" data-header="{{landing_page_header}}" data-size="{{landing_page_size}}" data-link="{{landing_page_link}}"></div>{{/landing_page_header}}
  
  {{#has_hero}}
  <div class="article-hero-container">
    
    {{#hero_image_url}}
    <img class="article-image" src="/{{hero_image_url}}" alt="{{hero_image_url}}" />
    {{/hero_image_url}}
      
    {{#hero_video_id}}
    <div class="hero-video-placeholder" data-hero-video-provider="{{hero_video_provider}}" data-hero-video-id="{{hero_video_id}}">
      <p class="video-no-js-message">Sorry, you must be using a <a href="http://browsehappy.com/" target="_blank">modern browser</a> with JavaScript enabled to view videos.</p>
    </div>
    {{/hero_video_id}}
  
  </div>
  {{/has_hero}}

  <div class="article-content">
    
    <div class="article-body">
      
      <div class="article-text"><div class="body-text">{{{text_html}}}</div></div>
      
      {{#has_tags}}
      <div class="article-tags">
        <ul class="tag-list">
          {{#tags}}
          <li class="tag-list-item"><a class="tag-list-link" href="/{{tag_link}}"{{#tag_video_previews_url}} data-video-previews-url="{{tag_video_previews_url}}"{{/tag_video_previews_url}}>{{tag_name}}</a></li>
          <b></b>
          {{/tags}}
        </ul>
        <div class="clear"></div>
      </div>
      {{/has_tags}}
      
      <div class="article-share-placeholder" data-share-url="{{share_link}}" data-share-title="{{share_title}}" data-share-text="{{share_text}}"{{#hero_video_iframe}} data-embed-code="{{{hero_video_iframe}}}"{{/hero_video_iframe}}></div>
      
    </div>
    
    <div class="article-collapsible-container">
      <div class="article-collapsible">

        {{#comments_enabled}}
        <div class="comments">
          <div class="comments-placeholder" data-comments-link="http://www.thrashermagazine.com{{comments_link}}"></div>
        </div>
        {{/comments_enabled}}
      </div>
    </div> <!-- .article-collapsible-container -->
    
  </div> <!-- .article-content -->

</div> <!-- .article --></script>

<script type='text/javascript'>
console.log("no Future Caching");</script></script>
<script>


(function(e,c,a,g,f){function d(){var b=c.createElement("script");b.async=!0;
b.src="//radar.cedexis.com/1/21597/radar.js";c.body.appendChild(b)}
(function(){for(var b=[/\bMSIE (5|6)/i],a=b.length;a--;)if(b[a]
.test(navigator.userAgent))return!1;return!0})()
&&("complete"!==c.readyState?(a=e[a])?a(f,d,!1):(a=e[g])&&a("on"+f,d):d())})
(window,document,"addEventListener","attachEvent","load");
</script>

</body>
</html>
